problems installing

Problems installing, a forum discussion on Jojo CMS. Join us for more discussions on Problems installing on our Installation forum.

Back to Forum Index : Back to Installation   RSS
rockstar rockstar

19 Jul 2007
Posts: 27

Hello everyone. i seem to be having a little problem installing jojo. My host[linux] allows unlimited domains/subdomains/databases.I want to get it installed to play with it and do not care about security that much. It will be in a subfolder anyway

I have a database ready for jojo. I have numerous cms installed too,and really did not have any problems installing any of them. They all basically created and located[if necessary] what was not uploaded by themselves during the install,and the permission changes were noted in the instructions so you could do it before you were in the middle of the install.I almost had it installed then i went to change some permissions and closed the freaking browser. I could never get back to that point.

when you say "you will find things" like "mysite folder and www/htaccess and index.php what do you mean I do not have it and cannot get into the install process without it I think.

also your image on the install instructions looks like for a local server wamp[htdocs] why not put an image of what a hosted server structure would look like.

I do have xampp installed, but choose to use the hosted account which has a very liberal php. everything within reason is basically enabled.



It seems thae the k-melon browser works as good as FF and for me it is way faster in every way. Neither browser has the wysiwyg editor working in the demo.

If someone could just go thru the install process starting with where to upload the files to and where to move what +what to create vs what should be there and so forth I would apreciate it.I would prefer to do it the secure way.with just the 3 files in root.

I have read and reread the instructions many times and I know I must be missing something...

I will let someone of the developers install it on my server if they want and they can review the host....who is exellent btw

www.ewebzone.net


Rockstar
Harvey

Core Developer

Harvey

19 Jul 2007
Posts: 327

Hi there,

To your credit, the installation instructions aren't very good and are something we need to get sorted. The install process has been under fairly heavy development so we have had to keep coming back and changing them :(

I'm quite happy to install Jojo on your server for you at no charge, and this offer applies to anyone. At the same time, I'll add the host to our approved hosts list and try to smooth out any glitches that are found during the install process.

One of the things we need to do with Jojo is test on more hosts, as it's so different between each one.

Just email or MSN messenger your FTP / MySQL details and I can get this underway.
rockstar rockstar

19 Jul 2007
Posts: 27

Thanks for getting back I will send an email.
Rockstar
Harvey

Core Developer

Harvey

20 Jul 2007
Posts: 327

Hey there Rockstar,

Your Jojo installation is now working on your server.

I have emailed passwords and folder locations, but the basic install went smoothly.

For this install, Jojo is running out of a folder - eg www.domain.com/jojo/

Jojo works well out of a folder, but there are a couple of things to keep in mind before you go live and decide to move to a root domain instead of a folder.

  • Firstly, the .htaccess needs to be changed. The easiest way to do this is to delete .htaccess and bring up your homepage in a browser. Jojo will detect the file is missing and give you the code to copy-paste into a new .htaccess file. It will autodetect whether Jojo is running in a folder or the root.
  • Next, run www.domain.com/setup/ in a browser, and click the "reset location link at the bottom". This will setup Jojo for the root instead of in a folder.
rockstar rockstar

20 Jul 2007
Posts: 27

well what have I done now. I deleted the .htaccess file and browsed to the home page and did see the home page, but without any styles. I think I may have put an empty .htaccess file in in place of the one that was there,so when I went to the site it did not detect there was no file. But I don't think so.I was going to but i think i deleted it too---not sure though.

Another thing I did was to change the template/theme [earlier today]. I did not know it was not fully ready to go or I would have changed back the template.If that was the problem or part of it.

Now I cannot get into admin ever or see the site with the old .htaccess there--if I renmame it or something I can see the site without styles

Any ideas on how I can fix this or get into admin and or get the right .htaccess code.

sorry/Thanks
Rockstar
Harvey

Core Developer

Harvey

20 Jul 2007
Posts: 327

Probably best if I login and take another look at it for you.

You only need to do those 2 steps I gave above when you decide to move to the root or a different folder, so if you were wanting to keep the install in www.domain.com/jojo/ then those above steps weren't needed.

Installing new themes should also be reasonably straightforward too...
  • Make a copy of one of the themes we provide in the base install, and rename it to anything you like.
  • Read up on Smarty template syntax at http://smarty.php.net
  • Make whatever changes you like to the template.tpl file and the CSS files.
  • Upload into the mysite/themes/ folder on your FTP.
  • Go to "customize" then "Manage Themes" in the Jojo Admin area. Click on the "install" button next to your theme, which should automatically appear in the list.


Themes should in general work even if they aren't finished. The whole point is you tweak your theme and test in the browser until it looks how you want it to.
Once we are a bit more established we should have a good library of basic themes to choose from, but for now it's roll-your-own themes :)
Harvey

Core Developer

Harvey

20 Jul 2007
Posts: 327

I have just looked on the server and there is something funky going on with the .htaccess file.

Something has added the following text to the top of the file...
.htaccess
File Type: ASCII text, with CRLF line terminators
----------------------------------------------

I commented this out and it worked first try. I'm not sure what software you are using for editing / transferring files, but I don't think this is normal.

Cheers,

Harvey.
rockstar rockstar

21 Jul 2007
Posts: 27

Thanks harvey. I think I just used notpad or more likely ted notpad.

Please see the post I made in the administration forum about the home icon in admin and the home link on the site itself not having the / added to it. Is this something that can be fixed by deleting the .htaccess file and running set up or did you do that already.
Rockstar
Harvey

Core Developer

Harvey

21 Jul 2007
Posts: 327

Please see my response on /topics/8/home-bad-request/
ducylowycz

27 Nov 2007
Posts: 6

Hey Harvey,

...I need installation help on my website. I already uploaded all the files however I get that 404 error when going to the root. I am new to this stuff but I already know that this looks to be a very promising application. Any help would be appreciated.

-Mike
barrey

3 Jan 2009
Posts: 1

Hey, there...
i have a problem to install jojocms on my localhost. actually i just want to try this CMS. but when i try to install on my computer (localhost) theres warning that displayed :
=====================================================
Apache Configuration

You must have the Apache mod_rewrite module enabled to run Jojo CMS on this server.

You will need to edit your /etc/apache2/apache2.conf or /etc/httpd/conf/httpd.conf or similar file and enable mod_rewrite. Within this file locate the line containing 'LoadModule rewrite_module' and ensure it is not commented out.

It should look similar to the line shown below, i.e. no '#' at the start of the line.
"...
#LoadModule proxy_http_module modules/mod_proxy_http.so
#LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
...
=====================================================
i using XAMPP as my server. i tried to add "#" at the front that warning said to me. i edit httpd.conf
when i save then restart my apache, warning still displayed.
please help me to solve this problem
and i want to ask, how to set permission on XAMPP windows ?

-----------------------------------------------------------------------------------------------
i really hope i can solve by myself, but i can't. please help me.
and sorry for my english
tom

Developer

tom

6 Jan 2009
Posts: 379

you need to remove the #, not add it.

this line
LoadModule rewrite_module modules/mod_rewrite.so
is the one you're looking for
if it has a # at the beginning, remove the #
glennn

8 Nov 2009
Posts: 2


YA THINK???

Harvey said...
Hi there,

To your credit, the installation instructions aren't very good and are something we need to get sorted. The install process has been under fairly heavy development so we have had to keep coming back and changing them :(





YA THINK???
Back to Forum Index : Back to Installation   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.