Broken pages

Broken pages, a forum discussion on Jojo CMS. Join us for more discussions on Broken pages on our Administration (backend and configuration) forum.

Back to Forum Index : Back to Administration (backend and configuration)   RSS
takshimada

18 Jul 2007
Posts: 7

Hello,
I've installed Jojo and the installation went smooth, I like it so far and hopefully I'll be able to use jojo for client sites also!

I have php5, mysql5, and apache2 (i think), and jojo 1.0a2 installed
The problem I'm having is in the admin section, when I click on the edit pages, or edit articles, or edit tags page, the whole page is broken and there's no content whatsoever. (http://blog.takshimada.info/uploads/brokenback.png).

Some other things, when I click uninstall for a plugin it doesn't get removed, and when I set options in the options page it doesn't save (ie. when I when I go to the main admin page, the options are reset again)
Thanks,
Takumi
Harvey

Core Developer

Harvey

18 Jul 2007
Posts: 327

Hi Takumi,

I suspect the issue may be to do with the Jojo admin section's incompatibility with Safari.

The Alpha version of Jojo is only tested in FireFox, and full support for Safari, Opera and IE7 is planned for the beta or full release (no plans to get the admin section working in IE6).

Please let me know if this fixes your problem, and sorry if this is an inconvenience for you (I know how much people love their browser).

Thanks,

Harvey.

mikec

Lead Developer

mikec

18 Jul 2007
Posts: 67

Hi Takumi,

We just tested it in Safari 3 on OSX here and the admin interface basically works. The WYSIWYG editor doesn't work.

What version of Safari are you using? Do the admin interface with for you in Firefox?

- Mike
takshimada

18 Jul 2007
Posts: 7

Harvey & Mike,
Thanks for the replies, I'm actually using Firefox, I just used Safari (3 beta) for the screenshot. Here's another screenshot in Firefox (ver. 2.0.0.4).
http://blog.takshimada.info/uploads/firefoxbb.png


I took a look at the HTML for the page, and actually Jojo never finished creating the page I guess. Here's a pastebin of the page:
http://pastebin.com/m5d90cf65

Thanks,
Takumi
Harvey

Core Developer

Harvey

18 Jul 2007
Posts: 327

Hi Takumi,

You are correct, it's a server side issue, not a browser issue.

I have found the problem and it appears to be a bad build of the Jojo download - there are some missing Xinha editor files causing the error you are seeing.

I have placed a patch onto the download page, or a direct link here.

The patch contains 3 folders, please unzip in the /BASEDIR/external/ folder on your server and this should resolve the problem.
takshimada

19 Jul 2007
Posts: 7

Harvey,
Thanks for the patch, it works fine now (and so does the updating of options)
Takumi
Back to Forum Index : Back to Administration (backend and configuration)   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.