Jojo Contact Plugin

Jojo Contact Plugin, a forum discussion on Jojo CMS. Join us for more discussions on Jojo Contact Plugin on our Administration (backend and configuration) forum.

Back to Forum Index : Back to Administration (backend and configuration)   RSS
rhcarter

31 May 2011
Posts: 27

I am having trouble with my contact pages on two of my installations and am a bit short of diagnostics. I can see no difference in the configuration from ones that work and they are all hosted by the same company.

On the contact page you get - "There was an error sending your message. This error has been logged, so we will attend to this problem as soon as we can."

on the error log is -
Today, 01:54pm enquiry more... Failed Enquiry from ..etc..

I did a test with PHP mail() and that worked fine -
<?php
$to = "myemail";
$subject = "Test mail";
$message = "Hello! This is a simple email message.";
$from = "dodgy@anything.net";
$headers = "From:" . $from;
mail($to,$subject,$message,$headers);
echo "Mail Sent.";
?>

The mail system does not care that the From email is not legitimate!

Where can I go from here?
Jaijaz Jaijaz

31 May 2011
Posts: 215

Hey can you gave us some more info please?

What version of Jojo are you using?

Can you give us the full error message please?

Thanks,
Jai
If you not living on the edge you taking up too much space.
rhcarter

2 Jun 2011
Posts: 27

I am using jojocms-1.0.0 and the error message is exactly as shown above, viz

On the contact page you get - "There was an error sending your message. This error has been logged, so we will attend to this problem as soon as we can."

The error log has no more information in it. Is there any way to turn on more error tracking so I can identify the issue?
tom

Developer

tom

3 Jun 2011
Posts: 379

The easiest way is to open up jojo_contact.php and insert some var_dumps to find the point at which it's failing and what is being set as the $to_email etc. or add those extra variable to what gets pushed to the log file. I suspect though that it's actually failing in the simpleMail function method in plugins/jojo_core/classes/Jojo.php

Is this site is using the smtp mail option (as opposed to the standard sendmail)?

you can also set debug=true in config.php in case there are some php errors you're not seeing.
rhcarter

4 Jun 2011
Posts: 27

Tom,
It is failing in the simplemail function -
It is very odd but I put some dump commands in the jojo.php core programme and after a few more times of testing it suddenly started working. I have carefully removed all the added code and it still works so I will get on to something more productive!
tom

Developer

tom

7 Jun 2011
Posts: 379

so the contact form is working on some sites? and they are all running off the same copy of Jojo? So it's not a problem with the plugin but with something in your config right?

If it's conflating the variables the most likely thing I can think of is something that's confusing the stitching operation, like perhaps a stray comma or quote mark.
Back to Forum Index : Back to Administration (backend and configuration)   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.