SSL not working

SSL not working, a forum discussion on Jojo CMS. Join us for more discussions on SSL not working on our Administration (backend and configuration) forum.

Back to Forum Index : Back to Administration (backend and configuration)   RSS
ayoub

3 Feb 2010
Posts: 39

Dear developers

I have a working self assigned ssl cert on my server. I checked the ssl page in technical tab for root admin page. When I type https://www.mydomain.com/admin I get the window to accept the certificate but then the page reloads in normal http://...

Is there any thing else to configure (maybe a rewrite rule) for this to work?

I'm using lighttpd.

If you need to check, website is [w,w,w].gimmi.[net]

Thank You in advance
Harvey

Core Developer

Harvey

3 Feb 2010
Posts: 327

SSL should only be used on select pages within a Jojo site. Jojo will actively redirect you from HTTPS to HTTP to avoid 2 copies of the same content being indexed in Google which causes trouble for your rankings (dupe content).

There is an option in Admin -> Options called "secureurl" - edit this to have your HTTPS address, no trailing slash.

Next, under edit pages on the "technical" tab, these should be a radio button called "secure" or similar. If you want the page to be served over SSL, set this option on each page. If you are doing a shopping cart website, the shopping cart plugin pages will have this set correctly by default.

If you are trying to serve the whole site securely, you might run into some bugs - this isn't something I have ever done before.

Certificates are best if they are the exact same domain as the non-secure site. Otherwise you will run into session / cookie sharing issues, as sessions are very hard to share across domains without mangling the URL. If I need a secure cert, I will get a $20 one from Godaddy rather than try and save money with a freebie shared cert.
Harvey

Core Developer

Harvey

3 Feb 2010
Posts: 327

Also, I'm not sure if using lighttpd makes any difference here - I wouldn't expect so.
ayoub

3 Feb 2010
Posts: 39

It's working great...Thanks

The problem was:

"There is an option in Admin -> Options called "secureurl" - edit this to have your HTTPS address, no trailing slash. "

I didnt see this field at first!! :)
Back to Forum Index : Back to Administration (backend and configuration)   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.