Editing Theme breaks site

Editing Theme breaks site, a forum discussion on Jojo CMS. Join us for more discussions on Editing Theme breaks site on our Themes Support forum.

Back to Forum Index : Back to Themes Support   RSS
erbuc

13 Oct 2009
Posts: 2

I am currently using the default REFRESH theme.

In the footer, the copyright date is 2006. I have gone into the TPL file and changed this to 2009. Once I upload changes going to the home page of the site results in a blank page.

So I go into the admin area to manage themes and it says it needs to be reinstalled. I click reinstall with no change on the home page.

The only way to restore the home page is to upload the original TPL file with the incorrect copyright date.

Can anyone point me to a resolution for this and tell me why this would be happening?

Thanks in advance.

Eric
Harvey

Core Developer

Harvey

13 Oct 2009
Posts: 327

If you are getting a blank screen, it's probably a PHP error of sorts. Can you please set debug mode to true in your config.php file and then try the homepage again - see if a useful PHP error is displayed (post the error here if it doesn't help you solve the problem).
tom

Developer

tom

13 Oct 2009
Posts: 379

if that's the only change, I wonder if it isn't an encoding issue - like your editor is somehow mangling the line endings when you save - some text editors (ones designed for word processing rather than coding) like putting odd invisible intro characters on the first line too, which php doesn't like at all.

JEdit is I think the one Mike uses on Windows, I use TextWrangler for Mac, but any text editor for coding (of which there are many) should be fine. If possible, set it to do Unix line endings, and encode for UTF-8 too.
tom

Developer

tom

14 Oct 2009
Posts: 379

Actually - most likely is that because RC2 uses the Dwoo template engine by default for new installs, there is something it doesn't like in the Refresh theme. Why it should only show up on editing I don't know, but I still think that's probably it.

Hopefully we can dump Refresh shortly, but I'll look at cleaning it for RC3 anyway.

In the meantime, best place to look for debugging Dwoo issues (it's a lot more powerful than Smarty but also a lot fussier) is in Admin > Reports > Eventlog
Back to Forum Index : Back to Themes Support   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.