how to migrate wordpress posts to jojocms?

How to migrate wordpress posts to jojocms?, a forum discussion on Jojo CMS. Join us for more discussions on How to migrate wordpress posts to jojocms? on our General Discussion forum.

Back to Forum Index : Back to General Discussion   RSS
raulandres

10 Jul 2009
Posts: 35

hello how to import posts from .xml file exported before on wordpress, any idea is wellcome, i think search or build a script rss2mysql tables, do you know one? thanks
raulandres

10 Jul 2009
Posts: 35

raulandres said...
hello how to import posts from .xml file exported before on wordpress, any idea is wellcome, i think search or build a script rss2mysql tables, do you know one? thanks


i'll try with simplepie... i tell you later...
Jaijaz Jaijaz

10 Jul 2009
Posts: 215

easy way would be to convert the xml to csv and then just import that with field mapping into your mysql database.
If you not living on the edge you taking up too much space.
raulandres

10 Jul 2009
Posts: 35

Jaijaz said...
easy way would be to convert the xml to csv and then just import that with field mapping into your mysql database.


ok thanks! what tool for fields mapping , do you know? is possible gui tool?
Jaijaz Jaijaz

10 Jul 2009
Posts: 215

If you host gives you access to the database through phpMyAdmin then there is a very good semi-GUI import screen in there. You specify the delimiters of the file then you can specify the order the fields appear in csv file.

Note that it is really import to make sure that the file is perfect in terms of has the right number of fields in the right order for every record.
If you not living on the edge you taking up too much space.
raulandres

13 Jul 2009
Posts: 35

hello Jaijaz, thx!, finally i run this query INSERT SELECT, its work, but now when browse blog, i get error 500 Internal Server Error, why?

INSERT INTO article SELECT wp_posts.ID as articleid, wp_posts.post_title as ar_title,'' as ar_desc, '' as ar_url, wp_posts.post_content as ar_body, wp_posts.post_category as ar_category, wp_posts.post_date as ar_date,'' as ar_image, '' as ar_livedate, '' as ar_expirydate, '' as ar_bbbody, 'yes' as ar_comments, wp_posts.post_author as ar_author, '' as ar_source, '' as ar_seotitle, '' as ar_metadesc, '' as ar_tags, '' as ar_language, 'Spanish' as ar_htmllang FROM wp_posts

Isn't is the finally good update query, for wp users when i fix it i post on this thread ;)
Jaijaz Jaijaz

13 Jul 2009
Posts: 215

Have you got PHP errors turned on in the options>config. That may give you a more meaningful error.

Is the rest of the site working OK?
If you not living on the edge you taking up too much space.
raulandres

13 Jul 2009
Posts: 35

yes i have enable php errors, and looking around reports -- event log but error 500 not appear there, the rest of site working ok...

another thing, not relation with this because it doesnt work for me from the first moment, is the leftbar on admin area doesnt load, for example, the tree for edit pages is imposible to look the diferents pages and select one page, this, im test on differents browse but not success. One observation, and i think so on relation with this, the css and images on admin pages, the button images not appear me and others styles i can see on jojo videos.

thx again Jaijaz
Jaijaz Jaijaz

14 Jul 2009
Posts: 215

hmm. Have you tried running setup again? This can be run at anytime by typing in URL domain.com/setup

Obviously replace domain.com with your sites URL.

Crazy but that has also fixed the sidebar issue in admin for me from time to time. Otherwise it could be some javascript not loading properly?? Also after setup is run try doing a Ctrl+F5 if you are on windows or holding down the Shift button while clicking on refresh if you are on mac.

What version of Jojo are you running?
If you not living on the edge you taking up too much space.
raulandres

16 Jul 2009
Posts: 35

yes, i ran /setup but doesnt work yet.

the version is jojo-nightly-2009-06-30, i dont touch anything about core javascripts

humm i dont know
raulandres

21 Jul 2009
Posts: 35

hello this is errors appear in event log when try browse /blog
i checking now the rss reader plugin...

Today, 02:34am PHP Error more... /home/.atomic/user/domain/jojocms/plugins/jojo_rss_reader/external/magpie/rss_fetch.inc "Undefined property: MagpieRSS::$etag" line 156
Error No: 8
Description: Undefined property: MagpieRSS::$etag
File: /home/.atomic/user/domain.com/jojocms/plugins/jojo_rss_reader/external/magpie/rss_fetch.inc
Line: 156

URI : blog
IP: 88.0.25.32 Browser: Firefox 3.0
Today, 02:34am PHP Error more... /home/.atomic/user/domain.com/jojocms/plugins/jojo_rss_reader/external/magpie/extlib/Snoopy.class.inc "Use of undefined constant gzinflate - assumed 'gzinflate'" line 426
Error No: 8
Description: Use of undefined constant gzinflate - assumed 'gzinflate'
File: /home/.atomic/user/domain.com/jojocms/plugins/jojo_rss_reader/external/magpie/extlib/Snoopy.class.inc
Line: 426

URI : blog
IP: 88.0.25.32 Browser: Firefox 3.0
Today, 02:34am PHP Error more... /home/.atomic/dev_collad/dev.collad.com/jojocms/plugins/jojo_rss_reader/external/magpie/rss_parse.inc "Undefined index: description" line 402
Error No: 8
Description: Undefined index: description
File: /home/.atomic/dev_collad/dev.collad.com/jojocms/plugins/jojo_rss_reader/external/magpie/rss_parse.inc
Line: 402

URI : blog
IP: 88.0.25.32 Browser: Firefox 3.0
Back to Forum Index : Back to General Discussion   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.