Article Categories

Article Categories, a forum discussion on Jojo CMS. Join us for more discussions on Article Categories on our Plugin Support forum.

Back to Forum Index : Back to Plugin Support   RSS
Jaijaz Jaijaz

8 Jul 2009
Posts: 215

So let me say first I already have at least one site working on this.

For some unknown reason I have a site where articles aren't showing. It is using categories. I have set it as per other sites with a unique page for each category.

After testing I can tell you:
The array of articles is being selected by category.
The right part of the if statement is being used in the php file for the plugin.
It appears that perhaps the index tpl file isn't being selected.

I am using a jojo version on this site from a recent (about two weeks old) svn. Going back to an early version and same one that is working on another site didn't fix it.

Anyone got any thoughts?

Thanks,
Jai
If you not living on the edge you taking up too much space.
tom

Developer

tom

8 Jul 2009
Posts: 379

the only show-stopping issue I've had with categories was when the url is hyphenated - there's something in the code somewhere that does cleaning on the url, removing the hyphen, and then it doesn't recognise the category.
Jaijaz Jaijaz

8 Jul 2009
Posts: 215

Hmmm. I have a site very happily working with hyphenated categories. Anyway in this instance the categories aren't hyphenated.

After doing a little more testing I feel the problem has nothing to do with the categories and something wierd happening where the tpl file is not being used or something.
If you not living on the edge you taking up too much space.
tom

Developer

tom

8 Jul 2009
Posts: 379

Do you get any useful error messages - in eventlog, through Charles or Webmaster tools? Is it a custom tpl?
Jaijaz Jaijaz

8 Jul 2009
Posts: 215

No nothing in the event log. After double checking that it was the standard tpl file like I thought I just found that my junor developer had put a copy of the tpl in the theme. Lost that and I now have articles, all be it not defined by category but that should be easy to fix.

Thanks for your help, Tom.
If you not living on the edge you taking up too much space.
Back to Forum Index : Back to Plugin Support   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.