Default language remains english

Default language remains english, a forum discussion on Jojo CMS. Join us for more discussions on Default language remains english on our Administration (backend and configuration) forum.

Back to Forum Index : Back to Administration (backend and configuration)   RSS
sakke

2 Jul 2009
Posts: 2

Hello.

First of all: Great work with JOJO! I really like it!

I'm using Jojo for the first time and I need to build a multi-language site.
Adding new languages and defining page / article -language relations works fine.
But I have a hard time setting the default language.

Even though the admin panel says that default language is what I set it to be (Finnish in this case), the site always directs to /english/ and I am unable to view any content with that language.
I browsed through the documents and forums but couldn't find anything related to this (which makes me think I just don't get something... :P )

Also I was wondering if there is a localization system for those hard coded texts such as labels and footers. Something like $localization[$current_lang].sometext
That would be a really useful as a plugin.

[edit]
And after a short googling I realized this can be done with smarty :)


Best Regards

Sakke
tom

Developer

tom

3 Jul 2009
Posts: 379

No, you're quite right - there seems to be a bug in the multi-language handling, I'll try to look at it in the next day or two.

As for customising template text, I use the jojo_translate plugin (available in svn). Enclose anything in templates with double hashes and it will check the translate table for a localised translation (it should work independent of default language settings)
tom

Developer

tom

3 Jul 2009
Posts: 379

Mike's found the issue and committed a fix, should be all good now in svn trunk.

Or, in jojo/plugins/jojo_core/classes/Jojo.php > static function parsepage:

change line 1787
- $language = 'en';
+ $language = Jojo::getOption('multilanguage-default', 'en');

You need to make sure that the home and root pages are set correctly for each language in both the language table and the lang_country table, but apart from that, it should just work.
sakke

14 Jul 2009
Posts: 2

That worked! thank you so much :)
Back to Forum Index : Back to Administration (backend and configuration)   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.