Images in Xinha

Images in Xinha, a forum discussion on Jojo CMS. Join us for more discussions on Images in Xinha on our General Discussion forum.

Back to Forum Index : Back to General Discussion   RSS
lynchpin

2 Apr 2009
Posts: 60

I am having trouble uploading images with Xinha. I think it started last week when I did an SVN update, but not sure. I also recently changed servers, so it could be that too.

When I choose an image to upload it acts like it is working for about the time it takes to upload, but then gets stuck and just says "Uploading" and the image doesnt show up.

Any ideas as to the problem?

Thanks
tom

Developer

tom

2 Apr 2009
Posts: 379

the /downloads/images/ folder has write permissions? and the image is less than the max image upload size (set through options - defaults to 2MB)?

Xinha has had a lot of updates of late (including a patch to fix a security hole in the image manager) - it might also be that you've got some old cached code. Empty the browser cache and the Jojo cache, or use Charles with no-caching on to be sure.
lynchpin

2 Apr 2009
Posts: 60

The folder has write permission.
image is less than 2MB

Looking into it more, it is a problem on all my Jojo sites using the same core files. I am guessing it is something in one of the updates. I will keep searching for the problem.

I just checked the Event Log too. I get this everytime I attempt an upload:
Error No: 8
Description: Undefined index: __function
File: /home/lpd02/jojo/plugins/jojo_core/external/xinha/plugins/ExtendedFileManager/backend.php
Line: 85

tom

Developer

tom

2 Apr 2009
Posts: 379

We're on the current Xinha here and I'm not seeing an issue - you sure your cache is clear? What browser/platform are you on?

There are definitely some issues with Xinha and the new jQuery menu tree in admin which Mike committed last week, which we're looking at, but not with the Extended File Manager
lynchpin

2 Apr 2009
Posts: 60

alright.
I tried the new menu tree update but had too many problems so I went back.

If you have a minute, I just setup a fresh site. Try the upload in Xinha and see what you think.

tom

Developer

tom

2 Apr 2009
Posts: 379

I've just committed a fix for xinha so it will play nice with the new version of jQuery that the new menu tree uses, so should be all good now.

It comes back with a failed request for the image uploader:
http://www.immixcms.com/external/xinha/plugins/ExtendedFileManager/backend.php? returns a 403 Forbidden - i suspect you need to reset the permissions on the Xinha folder to make sure it can read everything.

Charles is very handy for this kind of debugging (as well as forcing no-cache, substituting local files for external resources, checking response times etc etc):
http://www.charlesproxy.com/

lynchpin

2 Apr 2009
Posts: 60

thanks for checking that.
I tried resetting the permissions but no luck.
I will give Charles a shot next...never used it before but sounds pretty handy.
lynchpin

3 Apr 2009
Posts: 60

Turns out it was due to using the editor across domains, and mod_security was preventing the file upload from working. My host says that mod_security cannot be disabled on Apache 2 and they have to do it manually, which will be kind of a pain everytime I setup a new website.

Thanks for the help on figuring this out Tom.
Back to Forum Index : Back to General Discussion   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.