Previous Post

Previous Post, a forum discussion on Jojo CMS. Join us for more discussions on Previous Post on our General Discussion forum.

Back to Forum Index : Back to General Discussion   RSS
lynchpin

25 Mar 2009
Posts: 60

apparently some code I put in my previous post interferes with Jojo.
Sorry
Rick Rick

25 Mar 2009
Posts: 336

The error you were reporting about is in the bug tracker, with no response yet. http://bugs.jojocms.org/details/task141

Though it appears to be fixed in recent svn builds.

There are other issues with user content breaking things, but I haven't gotten round to reporting them.
lynchpin

25 Mar 2009
Posts: 60

oh yea, shoulda checked that first I guess.
I did just update to the most recent SVN version and still get the errors.

Thanks
Harvey

Core Developer

Harvey

25 Mar 2009
Posts: 327

Thanks for pointing this out Rick, will look into it.

As to the original question, this isn't anything to worry about, but we do want to tidy this part of things up.

The whole 'found/expected' thing comes about when we change field types of the database tables. We might for example decide one day to make a VARCHAR(30) into a VARCHAR(50) or other such changes, and the 'fix' button you see next to each item will attempt to do this for you.

But it does get stuck sometimes with case sensitivity things - in this case it thinks 'AUTO_INCREMENT' is not the same as 'auto_increment'.

The code that does all this isn't totally straightforward, and we don't want to simply ignore casing as database fields are case sensitive. Hopefully clean this up soon though.

Harvey.
tom

Developer

tom

26 Mar 2009
Posts: 379

jojo.php looks for any URI with /setup in it (anywhere) and runs setup if it finds it.
I can't see at this stage of the evening how to get around that and still be able to run it from any folder into the site (in those cases when you need to reset location) and still cope with the case of /? on the end (when you do reset location).

I'm guessing a regex would do it, but for now I've commited the addition of a trailing slash - presuming that's ok with all.

so to run setup you need to enter url/setup/
but you can view lynchpin's post about setup errors without it freaking out (until someone posts about setup....
Back to Forum Index : Back to General Discussion   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.