User Registration Problem

User Registration Problem, a forum discussion on Jojo CMS. Join us for more discussions on User Registration Problem on our General Discussion forum.

Back to Forum Index : Back to General Discussion   RSS
lynchpin

24 Jun 2008
Posts: 60

After a user registers through the link on the forum (mysite.com/register/) a success message shows along with a login box, but if you attempt to login you get errors. I just tried it on this site and the same thing happened.
Rick Rick

24 Jun 2008
Posts: 336

It's been there for a while in the Bug Tracker... (since early Feb). I've since gotten a bit more familiar with Jojo, but haven't looked at it again.
Harvey

Core Developer

Harvey

24 Jun 2008
Posts: 327

Sorry guys, here's a new template that should solve the issue. Unzip this and stick it in your jojo_forum/templates/ folder. Or, it's included in the SVN release from now on.

One of the cool things about the register page is you can throw it a return URL. So instead of linking to "domain.com/register/" you link to "domain.com/register/forums/" - after the registration is done, they will be redirected to "domain.com/forums", ie the same URL with register removed.
Changing that link seemed to make this problem go away.

Let me know if it does / doesn't solve it for you and I'll close off that bug tracker task. I'll fix the jojocms.org copy when we next to an update.

Thanks for the prompt :)

Harvey.

Attached Files

lynchpin

24 Jun 2008
Posts: 60

that did the trick. after reading your post i remember reading that in the release notes
JamesMcFall

15 Mar 2009
Posts: 6

I'm having a similar problem. My client wants people to be able to access her articles page only when they have registered.

So at the moment, someone can register, and then they get sent to the login page, and once you log in it takes you to the registration page, and the validation for all the registration form fields is triggered (the same as the problem above).

I used the link out of this forum template to pass the return URL through the register page, which seems to have solved that problem (as long as you don't click through from the home page, so it's still a problem).

The problem from there is, now that the user is signed in, the logout page does not log the user out.
Back to Forum Index : Back to General Discussion   RSS
You must be logged in to post a reply



You need to Register or Log In before posting on these forums.